Tuicemens

Pages: [1] 2 3

Author Topic: Dimming Issues  (Read 2156 times)

sniickers

  • Forum Supporter!
  • Full Member
  • *****
  • Helpful Rating: 0
  • Offline Offline
  • Posts: 33
Dimming Issues
« on: February 28, 2018, 03:32:21 PM »

Good afternoon! I recently tried using the dimming commands with SmartCloud. I seem to have an issue. When ever I call out a dim command regardless of the dim percentage  (I beleive it dims to the exact percent requested) smartcloud initiates the command but ends up turning off the light. I tried downloading the updated handlers in the other post. But it's downloading as an zip and not an editable note. But I recall you saying the right handlers are in the newest version of Alexa10. I setup the separate handlers for lamps and appliances also. Could I be missing something?

Here is my posted code:
}

// handle light levels
def setLevel(percent) {
if (percent == 0) {
      sendEvent(name: "switch", state: "off", value: "")
         put('off','')
}
if (percent==100){
sendEvent(name: "switch", state: "on", value: "" )
put ('on','')
}
else{
def brighten=[
     sendEvent(name: "switch", state: "bright", value: (percent))
   ]
def dim = [
sendEvent(name: "switch", state: "dim", value: (percent))
 ]
 put ('dim',percent)
}
}
//handles send command
private put(action,value) {

    def toReplace = device.deviceNetworkId

 if (value==""){
// do nothing as there is no value
  }
  else
  {
  action=(action +'%20'+ value)
   }

def params = [
//user replaces with their info Dnns or ip, port, username and port
    uri: "http://xxx.xxxx.xx.x:xxxxx/xxxxxxx:xxxxxx@code/$toReplace%20$action"

]

    httpGet(params)

}

Thanks in advance!
Logged

Brian H

  • Sr. Member
  • ***
  • Helpful Rating: 0
  • Offline Offline
  • Posts: 149
Re: Dimming Issues
« Reply #1 on: February 28, 2018, 03:54:22 PM »

Not sure if it makes a difference.
Are the modules being dimmed the newer Soft Start ones that turn On and Off at about a two second rate or instantly On and Off?
The older ones can not process extended commands the Soft Start ones can.
Logged

Tuicemen

  • Administrator
  • Hero Member
  • *****
  • Helpful Rating: 26
  • Offline Offline
  • Posts: 3711
  • Making Home Automation Fun!
    • Tuicemen.com
Re: Dimming Issues
« Reply #2 on: February 28, 2018, 05:30:26 PM »

The zip file needs to be unzipped to access the device handlers.
if the device is already off does it brighten with the dim command or turn on or do nothing?
Logged
Get the inside scoop and member perks in the
Members Only Section!

Please don't email me Automation questions 
The forum is for that!

sniickers

  • Forum Supporter!
  • Full Member
  • *****
  • Helpful Rating: 0
  • Offline Offline
  • Posts: 33
Re: Dimming Issues
« Reply #3 on: February 28, 2018, 05:40:12 PM »

They are the soft start ones. At least I assume. There is a slow from dark to 100 percent turn on. Some modules are instant on also. Been debating on upgrading all my modules to the Pro series PLM04 modules.
Logged

sniickers

  • Forum Supporter!
  • Full Member
  • *****
  • Helpful Rating: 0
  • Offline Offline
  • Posts: 33
Re: Dimming Issues
« Reply #4 on: February 28, 2018, 06:04:15 PM »

The zip file needs to be unzipped to access the device handlers.
if the device is already off does it brighten with the dim command or turn on or do nothing?

I did try and unzip the file, tried several zip apps, each one says there isn't anything to extract. File size is 2.66kb, but when I download (from several devices) the file size is 2.64kb. But I will try the suggestions you mentioned once I get home.
Logged

Tuicemen

  • Administrator
  • Hero Member
  • *****
  • Helpful Rating: 26
  • Offline Offline
  • Posts: 3711
  • Making Home Automation Fun!
    • Tuicemen.com
Re: Dimming Issues
« Reply #5 on: February 28, 2018, 06:33:44 PM »

Ok I tested the Zip file which may have been from prior to me moving the forum.
I also experienced issues with it so I updated the link and tested it. It should now work and include 4 device handlers.
I believe there is another thread with a zip file for the Device handlers so I'll check it as well
Logged
Get the inside scoop and member perks in the
Members Only Section!

Please don't email me Automation questions 
The forum is for that!

sniickers

  • Forum Supporter!
  • Full Member
  • *****
  • Helpful Rating: 0
  • Offline Offline
  • Posts: 33
Re: Dimming Issues
« Reply #6 on: March 01, 2018, 02:18:43 AM »

Okay I have tried requesting dim options from off to on. When the module is off, if I request a dim command it does nothing. No brighten or turn on.
Logged

Knightrider

  • Programmer
  • Full Member
  • *****
  • Helpful Rating: 5
  • Offline Offline
  • Posts: 65
  • Home Automator since 1988
    • This Automated House
Re: Dimming Issues
« Reply #7 on: March 01, 2018, 07:57:32 AM »

I probably shouldn't be posting on this, as I have no idea how the software works.

Does the software use ABSOLUTE Dim commands? I think there are extended codes(x10) for this, or are you using standard dim commands and stacking the steps based on percentages?

Not that this really helps, I'm just curious.
Logged
Tuicemen Software picks up where AHP left off!

Satisfied BVC user since November 2007

Proud Supporter of Xenia Kids and Robots. 
Introducing kids to high technology and teamwork since 2009.

Tuicemen

  • Administrator
  • Hero Member
  • *****
  • Helpful Rating: 26
  • Offline Offline
  • Posts: 3711
  • Making Home Automation Fun!
    • Tuicemen.com
Re: Dimming Issues
« Reply #8 on: March 01, 2018, 08:54:37 AM »

The software just uses standard dim commands out lined in the AHP SDK.
eg: sendplc, A3 dim 50%
There is no way to stack percentages with SmartThings as it doesn't. SmartCloud only does the sending of commands. If you send a Dim 50% then another Dim 50% a lamp will turn off but SmartThings sees the lamp as on at 50%
I have few softstart modules to test this with and all are the module type not wall switches.
Since most HA lamp settings with Alexa are just on/off/dim (no brighten commands) it is difficult to do a brighten or dim with any sort of accuracy.
I included brighten in the device handler in hopes that Brighten may get added for SmartThings.
The device handlers are editable by anyone so it may be possible an end user can come up with a more accurate means of Dim or Brightening lamps.
With x10 modules if you have dimmed to off (100%) you can't do a dim of any sort you have to send a On followed by a dim value
EG: "Alexa turn on Office lamp and dim 50%" (this may not work for everyone) or "Alexa turn on Office lamp". followed by "Alexa dim Office lamp 50%"
In my testing the dim does (did) work however I don't use the dim function anywhere near regularly so it is possible something has changed.

@ snickers
Are you using SmartCloud in stand alone mode or with Alex10?
Are you attempting to dim modules or wall switches?
Are you attempting to dim via Alexa voice or the SmartThings app or the Alex10 UI?
Knowing this will help point me in the right direction of where to look. 


 (Chr)
Logged
Get the inside scoop and member perks in the
Members Only Section!

Please don't email me Automation questions 
The forum is for that!

sniickers

  • Forum Supporter!
  • Full Member
  • *****
  • Helpful Rating: 0
  • Offline Offline
  • Posts: 33
Re: Dimming Issues
« Reply #9 on: March 01, 2018, 11:32:53 AM »

Good morning. I am using smartcloud with Alexa10. I am using only modules. I am using GH voice through smartthings. Also I monitored my AHP activity feed as I gave the dim command. Sometimes I will receive an off command when requesting dim. Sometimes it will request the dim, but it doesn't appear in the activity feed like it does when I use a palm pad to request dimming. Unfortunately I deleted the activity monitor activity before writing down. But I'll review when I get home. Thanks again for all the help.
Logged

Tuicemen

  • Administrator
  • Hero Member
  • *****
  • Helpful Rating: 26
  • Offline Offline
  • Posts: 3711
  • Making Home Automation Fun!
    • Tuicemen.com
Re: Dimming Issues
« Reply #10 on: March 01, 2018, 11:58:56 AM »

Ok I've a few Ideas to try.
Alex10 tries to keep track of the modules state that's why you see an Off command sometimes.
I thought I'd tested the dim with Alex10 but I may have only done it in standalone mode ::) :`)



Logged
Get the inside scoop and member perks in the
Members Only Section!

Please don't email me Automation questions 
The forum is for that!

sniickers

  • Forum Supporter!
  • Full Member
  • *****
  • Helpful Rating: 0
  • Offline Offline
  • Posts: 33
Re: Dimming Issues
« Reply #11 on: March 01, 2018, 03:48:04 PM »

Btw, did you ever update the smartcloud stand alone app to 32 bit? I really see no need to keep Alexa10 running on my pc. Already have PCC and AHP running and I use GH. So I rather just install the standalone or I could just install in PCC.
Logged

Tuicemen

  • Administrator
  • Hero Member
  • *****
  • Helpful Rating: 26
  • Offline Offline
  • Posts: 3711
  • Making Home Automation Fun!
    • Tuicemen.com
Re: Dimming Issues
« Reply #12 on: March 01, 2018, 05:13:37 PM »

SmartCloud is 32 bit it will not send x10 code if 64 bit as the SDK is 32 bit.
I believe only the first build was 64 bit.
I should have a new beta test build ready by weeks end with some new code options for Dims.

Logged
Get the inside scoop and member perks in the
Members Only Section!

Please don't email me Automation questions 
The forum is for that!

Tuicemen

  • Administrator
  • Hero Member
  • *****
  • Helpful Rating: 26
  • Offline Offline
  • Posts: 3711
  • Making Home Automation Fun!
    • Tuicemen.com
Re: Dimming Issues
« Reply #13 on: March 04, 2018, 08:26:34 AM »

Seems Soft Start modules ability to come on to previous dim state may be the issue here.
If dimmed to off the module still sees its self as On thus a On command and dim command don't appear to work as the modules still sees its self as on and dimmed fully.
The trick is to send either a Off or Bright 100 prior to any thing else.
Since many smart bulbs only use Dim and the SmartThings skill currently doesn't allow an Alexa brighten command a rework needs to be done.
The bit of code in the lamp device handles needs to be edited so this part
Code: [Select]
if (percent==100){
sendEvent(name: "switch", state: "on", value: "" )
put ('on','')
}
changed to this
Code: [Select]
if (percent==100){
sendEvent(name: "switch", state: "off", value: "" )
put ('off','')
}
I'll fix this in the next beta release of SmartCloud.
Also the current beta option for bright before dim needs a rework as it doesn't perform (for me at least) ::) :`)
I've not heard from anyone else on the performance of this option as yet.
Logged
Get the inside scoop and member perks in the
Members Only Section!

Please don't email me Automation questions 
The forum is for that!

Brian H

  • Sr. Member
  • ***
  • Helpful Rating: 0
  • Offline Offline
  • Posts: 149
Re: Dimming Issues
« Reply #14 on: March 04, 2018, 06:43:13 PM »

I have two Date Code LM465 Soft Start Lamp Modules. 09J44 and 08A01.
Mine will not dim to 0%. Stop at maybe 15%-20%.
That may complicate things even further. If the latest now can do 0%. As some may stop at not fully out while other do.
Logged
Pages: [1] 2 3